Setup

Feb 2, 2012 at 5:52 PM

I had to do the following to have a scheduled task run the powershell script:

  1. When the powershell script is run in the scheduled task, you need to disable the power shell execution prompts, run this command:
    set-executionpolicy bypass
  2. In the task scheduler start the Warmup power shell script as a parameter: C:\Windows\System32\WindowsPowerShell\v1.0\PowerShell.exe &'C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\WarmUp\WarmUp.ps1'
  3. Check if you able to browse the website url in IE, in my company's network, on a Windows server 2008 R2, when I browse locally to a sharepoint site, you will be prompted to enter credentials, which means Integrated Windows Auth (IWA) is failing, to solve that, set DisableLoopback check in registry: Create the Dword DisableLoopbackCheck key in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
  4. Reboot the Server for the registry key to take effect.
  5. If you are using a Load balanced URL for the SharePoint site, add the site url in “Trusted Sites” in IE.